Require login to checkout

by , ,
Odoo          
v 12.0 Third Party 1301
Download for 12.0 series Deploy on Odoo.sh
You bought this module and need support ? Click here !
Technical name website_sale_require_login
LicenseAGPL-3
Websitehttps://github.com/OCA/e-commerce
Read description for v 11.0 v 10.0 v 9.0 v 8.0
Required Apps eCommerce (website_sale)
Website (website)
Sales (sale)
Invoicing (account)
Included Dependencies

Require login to checkout

Beta License: AGPL-3 OCA/e-commerce Translate me on Weblate Try me on Runbot

This module extends the functionality of eCommerce to force users to login before buying anything in the website and allow you to get rid of those duplicated entries of returning unauthenticated users.

If you do not allow external users to sign up, this can serve you to make checkout available only for those that have a user account, and make some sort of members club.

Table of contents

Configuration

You probably want to enable any user to sign up:

  • Go to Settings > General Settings > Website > Customer Account.
  • Enable Free sign up.

Usage

To use this module, you need to:

  • Log out.
  • Try to buy something.
  • You will be forced to log in.

Bug Tracker

Bugs are tracked on GitHub Issues. In case of trouble, please check there if your issue has already been reported. If you spotted it first, help us smashing it by providing a detailed and welcomed feedback.

Do not contact contributors directly about support or help with technical issues.

Credits

Authors

  • Tecnativa
  • LasLabs

Contributors

Maintainers

This module is maintained by the OCA.

Odoo Community Association

OCA, or the Odoo Community Association, is a nonprofit organization whose mission is to support the collaborative development of Odoo features and promote its widespread use.

This module is part of the OCA/e-commerce project on GitHub.

You are welcome to contribute. To learn how please visit https://odoo-community.org/page/Contribute.

Please log in to comment on this module

Please choose a rating from 1 to 5 for this module.